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3 • W
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e 
Introduction

Purpose of the document
The Getting Results with RSLinx Classic™ guide provides you with information on how 
to install and navigate the RSLinx Classic software. It explains how to access and 
navigate the online help, and how to effectively use the RSLinx Classic software.

Intended audience
We assume that you are familiar with:

IBM-compliant personal computers
Microsoft® Windows® operating systems
OLE for Process Control® (OPC) communication
Microsoft dynamic data exchange (DDE) messaging
Allen-Bradley programmable logic controllers (PLC™)
Rockwell Software’s PLC programming tools

How does the getting results guide fit in with other Rockwell 
Software product documentation?

This getting results guide can be considered the entry point into Rockwell Software’s 
documentation set for this product. The documentation set contains pertinent, easily 
accessible product information and ships with the software product. This set ships with 
the software product, and is designed to free you from tedious paper shuffling and reduce 
information overload.

Other components of the documentation set include electronic release notes and online 
help.

Online help
The online help includes all overview, procedural, screen, and reference information for 
the product. The help contains these basic components: overview topics, quick start 
topics, step-by-step procedures, and screen element descriptions (for example, text boxes, 
drop-down lists, and option buttons). All of the help is context-sensitive with the 
application and provides you with immediate access to application tasks and screen 
element descriptions. Refer to the “Finding the information you need” chapter in this 
guide for a more detailed description of the online help.
1
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Note: This getting results guide, as well as any reference guides, are included in a portable 
document format (PDF) on your RSLinx Classic CD. These files must be viewed using the Adobe 
Acrobat Reader software, which you can download for free from the Adobe website 
(www.adobe.com).

Document conventions
The conventions used throughout this document for the user interface comply with those 
recommended by Microsoft. If you are not familiar with the Microsoft Windows user 
interface, we recommend that you read the documentation supplied with the operating 
system you are using before attempting to use this software.

Feedback
Please use the feedback form packaged with your software to report errors or let us know 
what information you would like to see added in future editions of this document. You can 
also send an email message to info@software.rockwell.com with any comments about 
Rockwell’s products and services.
2
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1 Welcome to RSLinx Classic
This chapter includes the following information:

What is RSLinx Classic?
Differences between RSLinx Classic types
Quick start
Exploring RSLinx Classic

What is RSLinx Classic?
RSLinx Classic for Rockwell Automation Networks and Devices is a comprehensive 
factory communications solution for use with the following operating systems:

Microsoft Windows XP, XP SP1, or XP SP2
Microsoft Windows Server 2003 SP1 or R2
Microsoft Windows 2000 SP4
Microsoft Windows Vista Business (32-bit) and Vista Home Basic (32-bit)

It provides Allen-Bradley programmable controller access to a wide variety of Rockwell 
Software and Allen-Bradley applications. These range from device programming and 
configuration applications such as RSLogix and RSNetWorx, to HMI (Human-Machine 
Interface) applications such as RSView32, to your own data acquisition applications using 
Microsoft Office, web pages, or Visual Basic®. RSLinx Classic also incorporates 
advanced data optimization techniques and contains a set of diagnostics. The Application 
Programming Interface (API) supports custom applications developed with the RSLinx 
Classic SDK. RSLinx Classic is an OPC Data Access Compliant Server and a DDE 
server.

Differences between RSLinx Classic types
RSLinx Classic is available in five versions to meet the demand for a variety of cost and 
functionality requirements. Depending on the version you are running, some functionality 
may or may not be operational. Refer to the following sections for specific version 
functionality.

The RSLinx Classic version you are running appears in the title bar at the top of the main 
window. If a version of RSLinx Classic is started without the proper activation files, it 
runs as RSLinx Classic Lite.
3
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RSLinx Classic Lite
RSLinx Classic Lite provides the minimum functionality required to support RSLogix and 
RSNetWorx. This version is not commercially available, but is bundled with products that 
require only direct access to the RSLinx Classic network drivers. This version does not 
support OPC, DDE, or the published RSLinx Classic C Application Programming 
Interface (API).

RSLinx Classic Lite is used for the following:

Ladder logic programming using RSLogix products.
Network and device configuration and diagnostics using RSNetWorx.
Configuring Ethernet modules/devices (for example, 1756-ENET, 1756-DHRIO, and 
so on).
Upgrading firmware using ControlFlash.
Browsing networks and getting device information such as firmware revision.

RSLinx Classic Single Node
RSLinx Classic Single Node includes the required functionality to supply 
communications services for all Rockwell Software products. OPC and DDE interfaces 
are supported, but to only one device. It does not support applications developed for the 
RSLinx Classic C Application Programming Interface (API) or direct drivers in HMI 
applications. RSLinx Classic OEM or higher is required for these application types.

RSLinx Classic Single Node is used for the following:

Data acquisition using OPC or DDE to only one device. This includes clients such as 
RSView32, Microsoft Office, Visual Basic, and web pages.
Ladder logic programming using RSLogix products.
Network and device configuration and diagnostics using RSNetWorx.
Configuring Ethernet modules/devices (for example, 1756-ENET, 1756-DHRIO, and 
so on).
Upgrading firmware using ControlFlash.
Browsing networks and getting device information such as firmware revision. 

RSLinx Classic OEM
RSLinx Classic OEM includes the required functionality to supply communications 
services for all Rockwell Software products. OPC and DDE clients are supported for any 
number of devices. It also supports applications developed for the RSLinx Classic C 
Application Programming Interface (API). 

RSLinx OEM Versions 2.2 and previous versions only supported AdvanceDDE. RSLinx 
Version 2.3 and subsequent versions support all DDE types except FastDDE.
4
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RSLinx Classic OEM is used for the following:

Data acquisition using OPC or DDE to any number of devices. This includes clients 
such as RSView32, Microsoft Office, Visual Basic, and web pages. 
Ladder logic programming using RSLogix products.
Network and device configuration and diagnostics using RSNetWorx.
Configuring Ethernet modules/devices (for example, 1756-ENET, 1756-DHRIO, and 
so on).
Upgrading firmware using ControlFlash.
Browsing networks and getting device information such as firmware revision.

RSLinx Classic Gateway
RSLinx Classic Gateway extends RSLinx Classic-based communications throughout the 
enterprise by connecting clients over TCP/IP networks. Programming and configuration 
products such as RSLogix and RSNetWorx use a local RSLinx Classic Lite or better with 
a Remote Devices via Linx Gateway driver configured to communicate to the RSLinx 
Classic Gateway. Remote HMIs and VB/VBA applications including Microsoft Office 
can use remote OPC to communicate to RSLinx Classic Gateway for data collection. This 
allows you to have multiple distributed computers performing data collection without 
having RSLinx Classic installed on each machine!

In addition to the capabilities provided in the RSLinx Classic Professional version, 
RSLinx Classic Gateway offers remote connectivity to:

Multiple RSView32 clients accessing data through one RSLinx Classic Gateway 
(remote OPC).
Remote PC running RSLogix connecting to a plant network over a modem for online 
program changes.
Remote Microsoft Office applications displaying plant floor data such as Excel.
A web page displaying plant floor data when the web server and RSLinx Classic are 
on separate computers.

RSLinx Classic for FactoryTalk View
If RSLinx Classic Lite (no activation present) is installed on a machine that has 
FactoryTalk View SE/ME, it uses FactoryTalk View's license to start as RSLinx Classic 
for FactoryTalk View.  However, please keep in mind that RSLinx Classic for FactoryTalk 
View:

In addition to supporting FactoryTalk View SE/ME as OPC clients, supports 
RSLadder 5/500 and Data Monitor.
Does not support RSView32, FactoryTalk Transaction Manager, RSTrend, WinView, 
RSLogix 5/500/5000 and third-party OPC clients.

Note: In RSLinx Classic v2.53 and later, RSLinx Lite enables OPC connectivity for FactoryTalk 
View SE/ME. 
5
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Quick start
This section outlines the main tasks you will need to perform to use the RSLinx Classic 
software. The quick start information included in this section is intended to be a high-
level, conceptual overview. When you are ready to use RSLinx Classic software, follow 
the detailed procedures found in the Quick Start, which is located in the RSLinx Classic 
online help. To access the online Quick Start, select Help > Quick Start from within 
RSLinx Classic. For information about specific controls on RSLinx Classic windows and 
dialog boxes, right-click any control.

Step 1 – Configure a driver
A driver is the software interface to the hardware device that will be used to communicate 
between RSLinx Classic and your processor. To configure a driver in RSLinx Classic, 
select Communications > Configure Drivers. The Configure Drivers dialog box 
appears, which is used for adding, editing, or deleting drivers. Select a driver to configure 
from the Available Driver Types list, click Add New, and complete the information 
required in the driver configuration dialog box that displays. The driver configuration 
dialog box varies depending on which driver you select.

After you 
complete the 
driver 
configuration, 
the driver 
name will 
appear in the 
Configured 
Drivers list.
6
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Step 2 – Configure a topic
In RSLinx Classic, a project is a storage container for one or more topics, and a topic 
represents a specific path to a processor. By grouping topics together in a project, you can 
make multiple topics available at the same time. Projects are created and edited in RSLinx 
Classic via the Open Project window, and topics are created and edited via the DDE/OPC 
Topic Configuration window. If you attempt to create a topic without creating a project, a 
default project is created for you.

If you selected Configure New DDE/OPC Topic by right-clicking a station in RSWho, the 
Topic Name field is pre-filled for you. RSLinx Classic starts with the name of the program 
running in the processor, and if this topic exists, it adds a number to the end until it finds 
one that does not exist. If there are any spaces, it converts them to underscores (_). You 
can change the topic name RSLinx Classic selected for you.

From the Data Source tab, select the device with which you wish to set up 
communication. To add a new topic to a project that already has at least one topic 
configured, click New. To edit an existing topic, select the topic from the list. Use the Data 
Collection tab to include more detailed information about specific topics.

Select an 
existing topic 
from the Topic 
List, and click 
the Data 
Collection tab 
to enter polling 
and packet 
information.
7
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Step 3 – Copy a link to the clipboard
RSLinx Classic provides a mechanism for easily establishing a link from RSLinx Classic 
to a compatible program.  It takes the information needed to create a link and places it on 
the Windows clipboard. Some packages support the ability to paste links from the 
clipboard. The Copy to Clipboard function can be used with these applications only.

The Copy to Clipboard function only establishes hot links from RSLinx Classic, the DDE 
server, to a Windows DDE client application. The Data Table Address, Block Size, 
Columns per Row, and selected topic are maintained from the last time that you used this 
function. Changing these values will have no effect on the last established link.

To use the Copy to Clipboard function, you must choose an RSLinx Classic project, and 
the selected project must contain topics.

Select the topic 
you just added 
in the 
DDE/OPC 
Topic 
Configuration 
dialog box, and 
browse for the 
address string 
for your 
request.
8
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Step 4 – Paste a link from the clipboard
Most Windows applications support a Paste Link operation, and this feature is generally 
located in the Edit menu.

Go to your application program that supports the Paste Link function. For example, in 
Microsoft Excel, click an open cell in a spreadsheet where you would like to place the 
data, select Edit > Paste Special, select Paste Link, and click OK. The hot link is pasted 
into the spreadsheet at the location you selected and begins to update. Note that if you 
select Paste, instead of Paste Link, the item string will get copied. 
9
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Exploring RSLinx Classic
When you start RSLinx Classic, the Rockwell Software RSLinx Classic application 
window appears. The application window contains a title bar, a menu bar, a tool bar, the 
application workspace where opened child windows (RSWho, diagnostics, and so on) are 
displayed, and a status bar.

Title bar
The title bar shows the RSLinx Classic icon, the name of the software product (for 
example, Rockwell Software RSLinx Classic Gateway), the RSWho instance number 
(RSWho - 1 opens by default when you open RSLinx Classic), and the Minimize, 
Maximize, and Close button.

To view the Control Menu, click the RSLinx Classic icon on the title bar. The following 
items appear on the Control Menu.

Item Description

Restore Restores the window to its former size after you enlarged it by using the 
Maximize command or shrunk it by using the Minimize command.

Move Allows you to reposition the window on the desktop using the arrow keys on the 
keyboard.

Size Allows you to resize the window by using the arrow keys on the keyboard.

Minimize Shrinks the window to an icon, which is located on the task bar. This performs 
the same function as if you clicked the Minimize button on the title bar.

Maximize Enlarges the window to occupy the entire screen. This performs the same 
function as if you clicked the Maximize button on the title bar.

Close Exits the RSLinx Classic application. This performs the same function as if you 
clicked the Close button on the title bar.
10
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Menu bar
The RSLinx Classic menu bar contains the following menus:

Each menu contains options for performing the following tasks:

Menu Description

File Create and open RSLinx Classic projects.

Edit Copy DDE and OPC links to the clipboard.

View Set and change RSLinx Classic interface displays, open the Event 
Viewer, and select the RSWho view.

Communications Configure drivers, topics, and other RSLinx Classic options, and view 
driver, DDE, other client application diagnostics.

Station Perform actions on diagnostic counters and view the Data Monitor.

DDE/OPC Configure DDE/OPC topics and view event and diagnostic information.

Security Set security user and access rights.

Window Arrange RSLinx Classic windows.

Help View help options for RSLinx Classic and other Rockwell Software 
products and services.
11
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Toolbar
The toolbar contains shortcuts to several commonly used RSLinx Classic functions. Each 
toolbar button is a graphical representation of a command that is also available from the 
RSLinx Classic menu bar. The following items appear on the RSLinx Classic toolbar.

Icon Menu Selection Description

File > Open Project Displays the currently defined projects and allows you to 
open a DDE/OPC project.

Communications > 
RSWho

Opens an additional instance of RSWho (one instance is 
opened by default each time you open RSLinx Classic).

Communications > 
Configure Drivers

Displays the currently configured RSLinx Classic 
software drivers and allows you to add additional drivers 
for use with your hardware devices.

Communications > Driver 
Diagnostics

Displays a list of currently configured drivers and 
provides the option to view diagnostic information for 
each driver.

Edit > Copy DDE/OPC 
Link

Provides the ability to create a DDE/OPC link between 
RSLinx Classic and a client application such as Microsoft 
Excel.

DDE/OPC > Topic 
Configuration

Allows you to create and modify a DDE/OPC topic, which 
is a specific path to a processor.

Help > What’s This? Changes the cursor to an arrow and a question mark to 
indicate you are in What’s This? help mode. Click any 
screen item to display help text for that item and to exit 
What’s This? help mode.
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Application workspace
The application workspace displays open child windows, such as the RSWho and RSLinx 
Classic dialog boxes.

Status bar
The status bar at the bottom of the RSLinx Classic screen provides information about the 
current status of your system.

The left area of the status bar is used to pass messages to the user. For example, when you 
scroll through the items on the menus, a brief description of the function of that menu item 
appears in this area of the status bar.

The right area of the status bar displays:

CAP, which is highlighted if the Caps Lock key on your keyboard is toggled for all 
caps.
NUM, which is highlighted if the Num Lock key on your keyboard is set to enable the 
numeric keypad on your keyboard.
SCRL, which is highlighted if the Scroll Lock key on your keyboard is set.
The current date from your computer’s system clock/calendar.
The current time from your computer’s system clock/calendar.
13
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2 Installing and Starting RSLinx Classic
This chapter explains how to install and start RSLinx Classic software. This chapter 
includes information on the following:

system requirements
installation procedure
updating an existing installation
starting procedure
troubleshooting installation

After installing the software, we recommend that you read the release notes located in the 
online help. The release notes may contain more up-to-date information than was 
available when this document was published. To view the release notes, start RSLinx 
Classic, and then choose Help > Release Notes from the main menu.

Before you begin
Rockwell Software uses a software key to implement copy protection for Windows-based 
software products. Every software product has a unique key.  Although, you can install the 
software on any number of computers, you are only licensed to run the software on one 
computer at a time. After you install the RSLinx Classic software, the Setup program will 
prompt you to activate your software. For more information about moving software keys, 
copy protection, and software activation, refer to Appendix A in this guide.

System requirements
To effectively use RSLinx Classic, your personal computer must meet the following 
minimum hardware and software requirements:

Hardware requirements
To install RSLinx Classic software, you will need the following hardware:

a Pentium 100MHz processor with at least 32 Megabytes (MB) of RAM. This version 
of RSLinx Classic will not run on Alpha, MIPS, or Power PC processors. 
at least 35 MB of available hard drive space; more hard disk space may be required for 
specific application features.
a 16-color, SVGA display with 800 by 600 or greater resolution.
a mouse or other Windows-compatible pointing device.
an Ethernet card and/or Allen-Bradley communications device or cable.
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Software requirements
To run RSLinx Classic, you require Microsoft Internet Explorer 6.0 (or later), and one of 
the following operating systems:

Microsoft Windows XP, XP SP1, and XP SP2.
Microsoft Windows 2003 SP1 or R2.
Microsoft Windows 2000 SP4.
Microsoft Windows Vista Business [32-bit] or Microsoft Windows Vista Home Basic 
[32-bit]

Note: Microsoft Windows Vista Business [32-bit] (Service Pack 1) or Microsoft Windows Vista 
Home Basic [32-bit] (Service Pack 1) is only required if you are also installing the FactoryTalk 
Services Platform. If you are not installing FactoryTalk Services Platform, RSLinx Classic will run 
on Microsoft Windows Vista Business [32-bit] or Microsoft Windows Vista Home Basic [32-bit]. 

Installing RSLinx Classic software
You can install one or more Rockwell Software products to a single personal computer.
Note: While installing RSLinx Classic software, you will have the opportunity to specify a 
directory. The suggested and recommended default directory is x:\Program Files\Rockwell 
Software\RSLinx where x is the letter of the drive to which you are installing RSLinx Classic. 
In procedures that appear throughout this document, it is assumed that you used the default 
name. If not, substitute the actual name you specified for the default name shown.

Note: To install RSLinx Classic, you must logon to your computer as an Administrator. 

To install RSLinx Classic software, perform the following steps:
1. Start your Windows operating system if it does not start automatically.
2. Insert the RSLinx Classic CD-ROM into the CD-ROM drive.

3. Follow the instructions that appear on the screen.

On the RSLinx Classic installation dialog box Click Release Notes to ensure your 
system meets the minimum requirements and to learn about new features included 
with this version of RSLinx Classic. After you have read the Release Notes, click 
Install RSLinx Classic.

If autorun is: Then:

enabled The Setup program starts automatically and the RSLinx Classic opening screen 
appears. Proceed to step 3.

disabled Perform the following steps:

1. Click Start, and then click Run. The Run dialog box appears.
2. In the Open control, type x:\setup, where x is the letter of the drive containing the 

RSLinx Classic CD-ROM, and click OK. The RSLinx Classic opening screen appears.
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On the Welcome dialog box Read the RSLinx Classic introductory information, and 
then click Next.
On the Software License Agreement dialog box Read the entire Software License 
Agreement. Enable I accept the terms in the license agreement and click Next to 
accept and continue installation, or enable I do not accept the terms in the license 
agreement and click Next to decline and exit the installation.
On the Customer Registration Information dialog box Type your user name, the 
name of your organization, and the serial number of your RSLinx Classic software, 
and then click Next.

Note: You can find the serial number on the product box label or the CD-ROM case.

On the Standard Setup dialog box Select the RSLinx Classic options you wish to 
install. You have options such as selecting a destination directory other than the 
default location, and selecting specific EDS files. Click Next.
On the Ready to Install the Program dialog box Click Install to start the RSLinx 
Classic installation process.
On the InstallShield Wizard Complete dialog box Specify if you wish to install 
activation and click Finish.  (For information on activation, refer to Appendix A in 
this guide). RSLinx Classic reverts to the Lite version if the proper activation is not 
installed. You must restart your computer before using RSLinx Classic. The RSLinx 
Classic installation is complete.

4. When you are finished installing the software, remove the RSLinx Classic CD-ROM 
from the CD-ROM drive and the Master disk from the disk drive. Store them in a safe 
place.

Updating an existing installation
Perform the following steps to update an existing RSLinx Classic installation:

1. Insert the RSLinx Classic CD-ROM into the CD-ROM drive and click Next on the 
Welcome dialog box.

2. On the Program Maintenance dialog box, enable Remove to remove RSLinx Classic 
from your computer.

3. Click Yes, and then Backup to backup your drivers and topics. Click Close to close 
the Backup/Restore dialog box.

4. Click Yes to remove EDS files from your computer.

5. At the Remove the Program dialog box, click Remove to confirm the uninstall 
procedure. 

6. After the uninstall procedure is complete, click Finish.
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7. Refer to the “Installing RSLinx Classic Software” section to install the updated 
version of RSLinx Classic. To restore the drivers and topics you backed up in step 3, 
click Start, and then select Programs > Rockwell Software > RSLinx > RSLinx 
Classic Backup Restore Utility.

Note: If activation was previously installed, it is not necessary to move the activation. If activation 
was not previously installed, insert the Master disk into the 3.5-inch disk drive and follow the 
instructions that appear on the screen. For more information on activation, refer to Appendix A in 
this guide.

Starting RSLinx Classic software
To start RSLinx Classic software, click Start, and then select Programs > Rockwell 
Software > RSLinx  > RSLinx Classic.

Note: We assume that you used the default names for the directory and program group. If you did 
not use the default names, substitute the actual names that you specified for the default names 
shown.

Troubleshooting installation
If RSLinx Classic does not start or run properly, consider the following:

Does your computer have enough memory? Running RSLinx Classic requires a 
minimum of 32 MB of RAM.
Does your computer have enough disk space? Running RSLinx Classic requires a 
minimum of 35 MB of available hard disk space.
Do you have the correct version of RSLinx Classic installed? If your RSLinx Classic 
installation displays as RSLinx Classic Lite, RSLinx Classic Single Node, or RSLinx 
Classic OEM, the proper activation files were not installed. From within RSLinx 
Classic, select Help > Copy Protection to view information about activation files.
Have you reinstalled an earlier Service Pack or removed a component, such as 
DCOM, that RSLinx Classic requires?
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3 RSWho
This chapter describes features of the RSWho network browser interface. RSWho allows 
you to view all the active network connections from a single screen.

Using RSWho
RSWho is RSLinx Classic’s main window that displays networks and devices in a style 
similar to Windows Explorer. A variety of integrated configuration and monitoring tools 
are accessible from the right mouse button in RSWho. Some of the available tools are the 
ControlLogix Gateway Configuration Tool for Controlnet, DeviceNet, Ethernet, 1756-
DHRIO, and 1756-DH485 modules, a Ladder Viewer for PLC-5, SLC, or MicroLogix 
family processors, and a Data Monitor for monitoring live data out of any ControlLogix, 
PLC-5, SLC, or MicroLogix family controllers.

The left pane of RSWho is the tree control, which shows networks and devices. The right 
pane is the list control, which shows all members of a collection. A collection is a 
network, or a device that is a bridge. Right-click in the list control and choose a view 
option of Large Icons or Details.

Note: A device that appears with a red X indicates that RSWho previously recognized this device, 
but now it can not. The red X indicates a communication status error, such as unplugging a 
recognized device. These devices can be removed from the RSWho display by right-clicking the 
device and selecting Remove.
19



RSLINX CLASSIC GETTING RESULTS GUIDE
•  

•  
•  

•  
•

RSWho browsing
The RSWho icon indicates a network. If this icon is animated, the network is being 
browsed. Click a network or device to start browsing.

When the network or device is collapsed (indicated by the + sign), click + or double-click 
the network or device icon next to the + to expand the view and begin browsing. When the 
network or device is expanded (indicated by the – sign), click – or double-click the 
network or device icon next to the – to collapse the view.

If the Autobrowse checkbox is enabled, RSWho continuously browses the selected device 
or network (regardless of whether or not the selection is expanded or collapsed). If 
Autobrowse is cleared, the Refresh button is active. Clicking Refresh instructs RSWho to 
perform one browse cycle of the selected device or network. Since Refresh only performs 
one browse cycle, clicking Refresh multiple times may be necessary to discover 
everything on the network.

Right-click a supported device to select Station Diagnostics, Configure DDE Topic, or 
other supported services for that device.
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4 OPC and DDE Connectivity
This chapter describes the features of:

OLE for Process Control (OPC)
Dynamic Data Exchange (DDE)

OLE for Process Control (OPC)
OPC, or OLE for Process Control, is a communication standard based on OLE technology 
provided by Microsoft and developed and maintained by the OPC Foundation, a coalition 
of industrial/manufacturing companies of which Rockwell Automation is a member. The 
charter of this group is to provide an industrial standard exchange mechanism between 
plant floor devices and client applications. RSLinx Classic is an OPC-compliant server 
exposing the required interfaces for an OPC client application to access data consistent 
with other OPC-compliant servers. The added benefit provided from RSLinx Classic is its 
ability to provide several DDE formats in addition to OPC.

OLE for Process Control (OPC) is designed to allow client applications access to plant 
floor data in a consistent manner. OPC provides many benefits:

Hardware manufacturers only have to make one set of software components for 
customers to use in their applications.
Software developers do not have to rewrite drivers because of feature changes or 
additions in a new hardware release.
Customers have more choices with which to develop world class integrated 
manufacturing systems.

With OPC, system integration in a heterogeneous computing environment is simple. 
Leveraging the OLE/COM environment is possible.

RSLinx Classic is an OPC-compliant server. For more information about OPC, visit the 
OPC Foundation web site at www.opcfoundation.org. For more information on using 
OPC with Rockwell Software products, visit our web site at 
http://support.rockwellautomation.com.
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Dynamic Data Exchange (DDE)
Dynamic Data Exchange (DDE) is a standard inter-application communication protocol 
built into Microsoft Windows operating systems and supported by many applications that 
run under Windows. DDE takes data from one application and gives it to another 
application. It allows Windows programs that support DDE to exchange data between 
themselves.

A DDE server is a program that has access to data and can provide that data to other 
Windows programs.
A DDE client is a program that can obtain data from a server.

By specifying an application, topic, and item, a client application can exchange data with 
a server application.

DDE works like a conversation between two people. The people represent the different 
applications running under Windows, and the data they share is what they are talking 
about. RSLinx Classic does not know the type of data it is receiving, it only knows that a 
DDE link is providing the data.

For example, if you have a DDE link from RSLinx Classic to an Excel spreadsheet, Excel 
does not know that you are sending a counter value into a spreadsheet. All Excel sees is 
data.

For example, RSLinx Classic is the application name, PLC5TOPIC1 is an example topic 
name, and C5:0.ACC is an example item, in this case a counter accumulator in an Allen-
Bradley PLC-5.

Note: Not all applications that run under Microsoft Windows support DDE. Check with an 
application’s manufacturer before purchasing an application for use with RSLinx Classic.

For more information about DDE, refer to the DDE (Dynamic Data Exchange) topic in 
the RSLinx Classic help file.
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DDE/OPC client connectivity
RSLinx Classic provides connectivity for client applications using OPC or multiple DDE 
data formats. The OPC and AdvanceDDE interfaces provide optimized read operations by 
packing multiple requests from multiple clients in a single transaction. In configuring a 
DDE Topic, you can specify whether or not you want DDE poke operations optimized. 
Optimized pokes only work with PLC-5 and SLC processors.

The benefit of optimizing DDE poke operations is packing multiple updates in a single 
write operation, thus reducing the overall number of packets required. Operations such as 
downloading a recipe can take advantage of this feature.

Other DDE formats supported include FastDDE (for Wonderware clients), XL_Table and 
CF_Text to support Microsoft Office products, and other generic DDE client applications.
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5 Finding the Information You Need
Use this chapter to review the sources of additional information about RSLinx Classic 
software. This chapter helps you to find what you need efficiently by describing how to:

Use the online help
Access online guides
Participate in Rockwell Software training courses
Contact Technical Support

Using the online help
RSLinx Classic online help provides general overview information, comprehensive step-
by-step procedures, and context-sensitive, dialog box control definitions for working with 
all of the features in the software. To view online help while running RSLinx Classic:

choose RSLinx Classic Help from the Help menu on the RSLinx Classic main 
window,
click Help on any RSLinx Classic dialog box or property page,
position the cursor over a control with which you want help and right-click, or
press F1.
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Accessing help for a control or field
To display a definition for a control or a field, click the What’s This? icon in the upper 
right corner of the dialog box, drag the cursor to the selected area, and then click to 
display the definition. In this example, the Property control was selected.
26



5 • FINDING THE INFORMATION YOU NEED
•  •  •  •  •

5 • Placeholder
Finding step-by-step procedures
To view a list of tasks related to the current topic, move to the What do you want to do? 
section at the bottom of the help window and select one of the listed tasks. The current 
topic is replaced with a step-by-step procedure for completing the task. 

For example, from the What is a driver? help topic, if you select Add a driver under the 
What do you want to do? section, the procedure that describes how to add RSLinx Classic 
drivers displays.
27



RSLINX CLASSIC GETTING RESULTS GUIDE
•  

•  
•  

•  
•

Finding definitions
Within the RSLinx Classic help, blue text highlighted with an underline indicates a link to 
a pop-up definition or a link to a related topic. For example, in the Dynamic Data 
Exchange help topic, application, topic, and item are pop-up definitions, and DDE link is 
a link to a related topic.
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Accessing online guides
You can gain immediate access to product documentation through the online guides 
included with RSLinx Classic. The online guides include this Getting Results Guide, as 
well as any reference guides, in an electronic book format. The online guides are included 
in a  portable document format (PDF) on your RSLinx Classic CD. These files must be 
viewed using the Adobe Acrobat Reader software, which you can download for free from 
the Adobe website (www.adobe.com).

Training
One of the best ways to increase your proficiency at using Rockwell Software products is 
to attend a Rockwell Software training program. Our training programs can help you 
master the basics and show you how to unleash the full potential of our software.

We offer a wide range of training programs, from regularly scheduled classes conducted at 
Rockwell Software facilities, to custom-tailored classes conducted at your enterprise. The 
size of each class is kept small intentionally to maximize student engagement. 

If you would like more information about our training programs, visit the Rockwell 
Software site on the World Wide Web or contact the Rockwell Software Training 
Coordinator. Our World Wide Web address and telephone numbers appear on the inside 
front cover of this document.

Note: For more information on Rockwell Software training, select Help > Support and Training 
from within RSLinx Classic

Technical support
If you cannot find answers to your questions in the Getting Results with RSLinx Classic 
guide, the online help, or the online guides, you can call Rockwell Software Technical 
Support at the numbers listed on the inside front cover of this guide. The technical support 
staff is available Monday through Friday from 8 A.M. to 5 P.M. Eastern Time, except 
holidays. You can also access the Rockwell Software Online Support Library from the 
web site listed on the inside front cover of this guide.
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When you call
When you call, you should be at your computer and prepared to give the following 
information:

product serial numbers
product version number
The product serial numbers and version number can be found in the software by 
selecting Help > About RSLinx Classic.
hardware you are using
exact wording of any errors or messages that appeared on your screen
description of what happened and what you were doing when the problem occurred
description of how you attempted to solve the problem
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A Activation
RSLinx Classic 2.54.00 (CPR 9 Service Release 1) supports two kinds of activation--
FactoryTalk and EVRSI. 

Notes: If you are a new user, you will need to activate your software using FactoryTalk Activation 
because RSLinx Classic no longer ships with a physical “master disk” for activating software. For 
more information, read the ‘Activate RSLinx Classic with FactoryTalk Activation’ section of this 
appendix. However, if you are a current user upgrading to RSLinx Classic 2.54.00, you can 
continue using EVRSI to activate your software. For more information, read the ‘Activate RSLinx 
Classic with EVRSI’ section of this appendix.  

EvRSI activation has been replaced by FactoryTalk Activation in the current release. If you are 
using EvRSI activation, please contact your local Rockwell Automation Sales office or Rockwell 
Automation Technical Support for information on migrating your activations to FactoryTalk 
Activation. For Rockwell Automation Technical Support in the U.S. call 1 (440) 646-3434. Outside 
the U.S. see http://www.rockwellautomation.com/locations/. 

Grace period
In RSLinx Classic v2.52.00 (CPR 9) and later, the software supports a seven day 
activation grace period when a valid activation is not found. During grace period:

When the software is started, a message is logged to the FactoryTalk Diagnostic log 
every four hours until a valid activation is found.

RSLinx Classic can be started an unlimited number of times. If the grace period ends 
and a valid activation has not been found, RSLinx Classic Lite is started. 

Note: If RSLinx Classic is unable to successfully obtain valid activations (for example, a network 
failure occurs), the software will attempt to run in grace period for up to seven days. 

Activate RSLinx Classic with FactoryTalk Activation
The type of FactoryTalk Activation RSLinx Classic 2.54.00 (CPR 9 Service Release 1) 
supports is called concurrent activation. A concurrent activation allows multiple 
computers across a network to use Rockwell Software products at the same time. There 
are two kinds of concurrent activations:

floating activations - activations that “float” from an activation server to any 
computer on a network that needs them.

borrowed activations - activations that are retrieved from a server for a specific 
period of time before expiring and returning automatically to the pool of available 
activations on the server. 
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Notes: You can only borrow RSLinx Classic v2.54.00 activations if you are running RSLinx 
Classic as an application. If you are running RSLinx Classic as a service, you cannot borrow 
activations. 

RSLinx Classic v2.53.00 (CPR 9) and earlier supported local "node-locked" activation and mobile 
"node-locked" activation. 

How to activate RSLinx Classic
To activate your copy of RSLinx Classic, perform the following steps: 

1. Install the FactoryTalk Activation Client available from the Optional Steps screen of 
the Install program. 

2. Once FactoryTalk Activation Client is installed, select Start > Programs > Rockwell 
Software > FactoryTalk Activation > FactoryTalk Activation Tool to launch the 
FactoryTalk® Activation Tool.

3. Click the Get Activations tab. 

4. Click the Open Activation Wizard button. Follow the instructions in the wizard. For 
more information on using the FactoryTalk® Activation Tool, see the FactoryTalk 
Activation Tool online help.

Finding more information about FactoryTalk Activation
For help with FactoryTalk Activation at any point, you can click:

the Help button on any FactoryTalk Activation Tool dialog or FactoryTalk Activation 
Transfer Tool dialog
the Help link on the Rockwell Software Activation website: 
http://licensing.software.rockwell.com
View How to Activate Rockwell Software Products on the Required Steps of the 
Install program

If you cannot connect to the Internet, call Technical Support for help creating an 
activation file from an e-mail or a fax. 

Phone:  440-646-3434 in North America. Outside of North America, call your local 
support organization.
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Activate RSLinx Classic with EVRSI
Rockwell Software’s products are copy-protected. Only a computer with access to the 
activation key can run the software. The key is located in an activation file, which is 
located on the Master disk supplied with the RSLinx Classic product. The activation file 
contains one activation key per product. Each key contains one or more licenses 
depending on how many copies of the product you have purchased.

Note: Store your Master disk in a safe place. If your activation becomes damaged, the Master 
disk may be the only means to run your software in an emergency.

During the setup process, the setup program gives you the opportunity to move the 
activation file from the Master disk to the root directory of the drive on which you’re 
installing the software.

When you launch RSLinx Classic, the software first checks your local hard drives, then 
network hard drives, and finally local floppy drives for activation. If the system fails to 
detect either the activation file or the Master disk, your software reverts to the RSLinx 
Classic Lite version.

Note: Systems attached to extensive networks can take quite a while to search for activation files 
on all available drives. You can use the CHECKDRIVES environment variable to specify and/or 
limit the drives your software checks for activation files and to specify the order in which they are 
checked. Refer to the activation utilities online help file by selecting Help > Copy Protection.

How to activate RSLinx Classic
Depending on your needs, you can activate RSLinx Classic from any of the following:

Hard drive. The activation key resides on your computer’s hard disk. Use this method if 
you will typically use RSLinx Classic on only one computer. This is the default method if 
you activate RSLinx Classic during installation. To run RSLinx Classic on a different 
computer, move the activation key back to the Master disk, and then to the hard drive of 
the new computer.

Diskette drive. The activation key resides on a floppy disk (activation disk). Use this 
method if you will typically use RSLinx Classic on more than one computer, for example, 
if you want to run RSLinx Classic on a desktop computer at some times and a portable 
computer at others.

Network drive. The activation keys reside on a network drive. Use this method if you 
have purchased multiple licenses of the software and want several users to be able to 
activate the software over a network. Refer to the online help for instructions on moving 
activation to a network drive (refer to the “Finding more information about activation” 
section in this chapter to access online help).
33



RSLINX CLASSIC GETTING RESULTS GUIDE
•  

•  
•  

•  
•

Protecting your activation files

To avoid damaging your activation files, do not perform the following operations with 
activation files on the hard drive. 

Restore from backup
Upgrade the operating system
Compress or uncompress the hard drive 

Defragmentation utilities will not harm activation files.

Before running any type of utility that may modify the structure or organization of the 
hard drive, remove activation from the hard drive:

1. Use the Move Activation utility (EvMove) to move activation files from the hard 
drive to an activation disk.

Run EVMOVE.EXE from your hard drive (located in C:\Program Files\Rockwell 
Software\RSUtil if you accepted the default directory location during installation).

2. Perform the hard disk operation.

3. Move the activation files back to the hard drive.

Certain anti-virus software packages, such as Norton Anti-virus, can corrupt the activation files. 
Configure your anti-virus software to avoid checking the files EVRSI.SYS and 386SWAP.PAR.

Do not use the the Move Activation utility if Rockwell Software products are currently running. 
Ensure all software programs are closed before initiating the EvMove utility.

You must use the move utility, EvMove, to move activation files. Attempts to copy, move or e-mail 
an activation file by other means will damage the file.
34



A • ACTIVATION
•  •  •  •  •

A • Placeholder
RUNNING THE ACTIVATION UTILITIES

The utilities for moving and resetting activation are called EvMove and Reset 
respectively. Reset is used when an activation file has been damaged. The 
EVMOVE.EXE and RESET.EXE files are located on your hard drive (located in 
C:\Program Files\Rockwell Software\RSUtil if you accepted the default directory location 
during installation). To run these programs, select Start > Progams > Rockwell Software 
> Utilities > Move Activation or Reset Activation.

Some common questions
Following are some common problems that people encounter with activation and their 
solutions.

MY ACTIVATION FILES WERE DAMAGED. WHAT SHOULD I DO?
If you have lost the activation because the activation file is damaged, you need to reset 
activation. Follow the Reset Codes instructions on the Rockwell Software Technical 
Support web page, or call the technical support telephone number. The web page and 
telephone number are both listed on the inside front cover of this guide.

If you cannot obtain a reset code immediately, follow these instructions to use the Master 
disk to activate the software as a temporary solution.

To use the Master disk to activate software:

1. Set the KEYDISK environment variable to TRUE. (Please refer to the online help.)

2. Insert your Master disk in the floppy drive.

3. Run your software as usual. Your software will find the activation on the Master disk.

I ACCIDENTALLY DELETED THE SOFTWARE DIRECTORY ON MY HARD DRIVE. 
DO I NEED TO CALL ROCKWELL SOFTWARE FOR REPLACEMENT 
ACTIVATION FILES?
No. Deleting the program files does not delete your activation. The activation files are not 
stored in the program directory; they are located in the root directory. Your activation files 
will not be lost unless you format the hard drive, tamper with hidden files in the root 
directory, or perform certain other hard drive operations (refer to the “Protecting your 
activation files” section in this chapter for more information).

To get the software running again, simply reinstall the software, but do not move the 
activation when given the opportunity.
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WHY CAN’T I MOVE ACTIVATION TO A NEW FLOPPY DISK ON A WINDOWS 
NT SYSTEM?
It has to do with a disk modification that NT does not allow. If you have access to a 
machine with a different Windows operating system, you can create a disk that will work 
under NT. Format a floppy and move any activation file to it under Windows XP, 2000, 
Me, or 98. (You can move the activation back off the disk if you want to keep it where it 
was.) Then take that disk to your Windows NT machine and move the activation to it.

Finding more information about activation
The online help (COPYPROT.HLP) provides more extensive information on activation 
including subjects such as:

KEYDISK. Set this environment variable to tell your computer to look for activation on 
floppy drives

CHECKDRIVES. Specify which drives to search for activation

network activation. Move activation to a network server to allow multiple users access to 
the activation

moving activation. See detailed instructions for moving activation

resetting activation. See detailed instructions for using the Reset utility to repair a 
damaged activation file

troubleshooting. Look up error messages, get problem-solving suggestions

You can access online help:

from the Help button on one of the EvMove or Reset dialog boxes.
from RSLinx Classic by selecting Help > Copy Protection from the main menu.
without running either RSLinx Classic or the activation utilities. From the Windows 
Start menu, select Programs > Rockwell Software > Utilities > Activation Help (if 
you accepted the default directory location during installation).
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B Secure RSLinx Classic with FactoryTalk 
Security

FactoryTalk Security™ is intended to improve the security of your automation system by 
limiting access to those with a legitimate need. FactoryTalk Security authenticates user 
identities and authorizes user requests to access a FactoryTalk-enabled system. These 
security services are fully integrated into the FactoryTalk Directory and are included as 
part of the FactoryTalk Services Platform that installs with many products.

For more information on how to use security services, please refer to FactoryTalk 
Security’s Online help.

How do I set up security in RSLinx Classic?
RSLinx Classic 2.54.00 (CPR 9 Service Release 1), along with supporting RSSecurity, 
also supports FactoryTalk Security. FactoryTalk Security™ is intended to improve the 
security of your automation system by limiting access to those with a legitimate need. 
FactoryTalk Security authenticates the identities of users and authorizes user requests to 
access a FactoryTalk-enabled system against a set of defined user accounts and access 
privileges held in the FactoryTalk Directory. For more information on FactoryTalk 
Security, read the ‘About FactoryTalk Security’ topic located in RSLinx Classic’s Online 
Help.  The following table explains the steps you would need to perform to implement one 
of the two security mechanisms (FactoryTalk Security and RSSecurity) supported by 
RSLinx Classic. 

If you are... Do this...

a user who wants to:

use FactoryTalk Security, 
and

has never configured 
security using RSSecurity

1. Install FactoryTalk Services Platform from the RSLinx Classic 
Optional Steps Install screen.  (During the FactoryTalk Services 
Platform install you configure the FactoryTalk Directory.) 

2. Install RSSecurity Emulator from Start > Programs > Rockwell 
Software > FactoryTalk Tools > RSSecurity Emulator.  
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Note: During RSSecurity Emulator install, the ‘FactoryTalk 
Directory’ screen appears (see the following figure) where you will 
be prompted to select the FactoryTalk Directory (Network or Local) 
that RSSecurity Emulator should use.  At this step, be sure to make a 
note of the directory you choose -- you will require this information 
when adding security policies to FactoryTalk Directory in step 5.

3. Install RSLinx Classic from RSLinx Classic Required Steps 
Install screen.  

4. While running RSLinx Classic’s installation wizard, the Security 
Configuration Selection screen appears.  On this screen, select the 
‘Enable Security’ option.

If you are... Do this...
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5. Click Next to finish RSLinx Classic install.

6. Open FactoryTalk Administration Console from Start > 
Programs > Rockwell Software > FactoryTalk Administration 
Console to add user accounts and set security settings to secure 
RSLinx Classic.

Note:

For more information on how to add user accounts, read the Add 
a user account topic in FactoryTalk Administration Console help, 
located at Manage FactoryTalk-enabled systems > Log on and 
configure security > Configure security > How To > Work with user 
accounts > Add a user account.

For more information on how to secure RSLinx Classic's features, 
read the Secure Product Features topic in FactoryTalk Security help, 
located at Configure Security > How to > Set up product policies > 
Secure product features.

For more information on what you can secure in RSLinx Classic, 
read the What can I secure in RSLinx Classic topic in RSLinx Classic 
Online help, located at How to > Secure RSLinx Classic with 
FactoryTalk > What can I secure in RSLinx Classic.

7. Open RSLinx Classic from Start > Programs > Rockwell 
Software > RSLinx > RSLinx Classic, and select Security > Set 
Security User from the main menu.  In the New User dialog box, 
enter the username and password of the user you created in 
FactoryTalk Administration Console in step 6, and click OK.

Note: Because access to features in RSLinx Classic is governed by 
the permissions you set for a user in FactoryTalk Administration 
Console, some features out of the 13 securable features in RSLinx 
Classic may be inaccessible (for example, if the user you entered in 
step 7 does not have the appropriate permission). 

This completes the security setup for RSLinx Classic. 

If you are... Do this...
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a user who wants to:

use FactoryTalk Security, as 
well as

import an existing 
RSSecurity Configuration into 
the FactoryTalk Directory

1.  Install FactoryTalk Services Platform from the RSLinx Classic 
Optional Steps Install screen. (During the FactoryTalk Services 
Platform install you configure the FactoryTalk Directory.)

2. Launch the Security Config Explorer by selecting Start > 
Programs > Rockwell Software > Security Server Network 
Edition > Security Config Explorer.

3. Locate the RSSecurity Configuration (*.bak) file, and select File 
> Export to backup the *.bak file.

4. Close the Security Config Explorer.

5. Uninstall RSSecurity Server/Client (whichever is installed on this 
machine) from Start > Settings > Control Panel > Add/Remove 
Programs. 

6. Install RSSecurity Emulator from Start > Programs > Rockwell 
Software > FactoryTalk Tools > RSSecurity Emulator. 

Note: During RSSecurity Emulator install, the ‘FactoryTalk 
Directory’ screen appears (see the following figure) where you will 
be prompted to select the FactoryTalk Directory (Network or Local) 
that RSSecurity Emulator should use.  At this step, be sure to make a 
note of the directory you choose — you will require this information 
when importing the .bak file into the FactoryTalk Directory in step 
10.

If you are... Do this...
40



B • SECURE RSLINX CLASSIC WITH FACTORYTALK SECURITY
•  •  •  •  •

B • Placeholder
7. Install RSLinx Classic from RSLinx Classic Required Steps 
Install screen. 

8. While running RSLinx Classic’s installation wizard, you will see 
the Security Configuration Selection screen.  On this screen, select 
the ‘Enable Security’ option. 

If you are... Do this...
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9. Click Next to continue with the installation. 

10. Import RSSecurity Server database by launching Start > 
Programs > Rockwell Software > FactoryTalk Tools > Import 
RSSecurity Configuration. 

Note: While running the Import RSSecurity Configuration utility, you 
will see the ‘FactoryTalk Security Import’ dialog box (see the 
following figure).  In the ‘Destination’ listbox on this dialog box, be 
sure to import the .bak file to the directory where you installed the 
Emulator (see step 7).  (Selecting the default option in the destination 
field stores your file in the Network directory.)

11. Open RSLinx Classic, and select Security > Set Security User 
from the main menu.  In the New User dialog box, enter the 
username (domain name\username) and password of the RSSecurity 
user.  

Note: If you do not remember the usernames of the users that existed 
in your old RSSecurity setup, perform the following steps:

a. Launch FactoryTalk Administration Console by selecting Start > 
Programs > Rockwell Software > FactoryTalk Administration 
Console.

b. In the Explorer pane, expand the FactoryTalk Local or Network 
Directory tree, and then expand the Systems folder until the Users 
folder is visible. 

c. In the Users folder, the users who have domain associated with 
their usernames (for example, na\Bob) are your RSSecurity users.

Note: Because access to features in RSLinx Classic is governed by 
the permissions you set in the security server, some features out of the 
13 securable features in RSLinx Classic may be inaccessible (for 
example, if the user you entered in step 11 does not have the 
appropriate permission). 
This completes the security setup for RSLinx Classic.

If you are... Do this...
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What can I secure in RSLinx Classic?
The following table explains the features you can restrict access to in RSLinx Classic.  For 
example, you might restrict the ability to shut down the RSLinx Classic service to a small 
group of users, to prevent parts of your automation system from going down at runtime.

Note: If you selected Network Directory during the RSLinx Classic security setup procedure, you 
must use FactoryTalk Security to secure the following list of features. For more information, 
please contact your local Rockwell Automation distributor.
.

Securable feature Description

Clear DDE/OPC Event Log Displays information on any DDE/OPC error messages logged 
while running RSLinx Classic with DDE/OPC compliant programs.

Configure CIP Options Administers how PCCC requests that use the CIP protocol are sent 
over networks.

Configure Client Applications Maps configured and running RSLinx Classic drivers to legacy 
INTERCHANGE C API, as well as displays the link identifier of 
the virtual network maintained by RSLinx Classic for the use of 
Client Applications in the virtual link unsolicited messaging model.

Configure ControlLogix 
Gateway

Provides you with information about the modules in your 
ControlLogix Gateway.

Configure DDE/OPC Topic Configures DDE/OPC topic.

Configure Drivers and 
Shortcuts

Configures (add, edit, or delete) drivers and shortcuts that allow 
RSLinx Classic to communicate with your PLC, as well as provide 
quick access to specific networks.

Configure Gateway Allows you to enable the RSLinx Classic Gateway.

Configure Network Properties Allows you to configure network properties.

Edit DDE/OPC Project Allows you to edit your DDE/OPC project.

Edit Options Displays the options dialog box which contains the General and 
DDE tabs.

Reset Station Diagnostic 
Counters

Clears the counters in the station diagnostic screens.  

Shutdown Shuts down RSLinx Classic.

View NT Event Log Records important system occurrences such as RSLinx Classic 
drivers successfully starting and stopping.
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Considerations when using RSLinx Classic with FactoryTalk 
Security

Keep the following in mind when using RSLinx Classic with FactoryTalk Security:

NETWORK/LOCAL DIRECTORY 
The FactoryTalk Services Platform can install two completely separate and independent 
FactoryTalk Directories: a Local Directory and a Network Directory.  User accounts, 
passwords, and security permissions to securable features are completely separate and 
cannot be shared between the Network Directory and the Local Directory. Configuring 
any of these items on one directory does not configure them on the other. Similarly, 
changing the password to a user account in one directory does not change the password 
the other directory, even if the account has the same name in both directories.

When configuring RSLinx Classic to work in one of the two directories, please keep the 
following in mind :

RSLinx Classic’s security policies and RSSecurity Emulator must be installed in the 
same directory (either Local or Network).
If you configured RSLinx Classic to work in the Network Directory, you must use 
FactoryTalk Security to administer centralized security across the network. 

If you configured RSLinx Classic to work in Local Directory and want to use 
FactoryTalk Security, you can administer security only on a single computer. 
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RESET NETWORK TREE

When RSLinx Classic is reinstalled, all security settings that were previously configured 
for networks and devices are lost. You must redefine these security settings in the 
Networks and Devices tree, or in RSWho. For more information, read the Network and 
Devices are not displayed correctly topic in FactoryTalk Security’s help, located at 
Configure security > Troubleshooting security > Network and Devices are not 
displayed correctly.

MISCELLANEOUS

Keep the following additional FactoryTalk Security considerations in mind:

If you did not check 'enable security' option during RSLinx Classic install, but want to 
enable security now, you will need to uninstall and then reinstall RSLinx Classic.

Every time you are in RSLinx Classic, be sure to verify that the Username displayed 
in the Current Security User text box of the Set Security dialog box (Security > Set 
Security User) is correct.  If it is incorrect, enter the new Username and Password, 
and click OK.
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Activation disk — Any disk (floppy or hard) containing an activation file. An activation 
disk can be used to activate the software. This is different from a key disk (Master Disk) 
in that at least one license of the software must be available on the activation disk to 
activate the software.

Activation file — A hidden, read-only, system file that “activates” a Rockwell Software 
product. The software will run only if your system can find the correct activation file.

Activation key — Activation files contain a database of activation keys. Each key is 
particular to a certain product and must be accessible on a local or remote drive for that 
product to run.

Driver — The software interface to the hardware device that will be used to 
communicate between RSLinx Classic and your processor.

Dynamic Data Exchange (DDE) — A form of inter-process communication. When two 
or more programs that support DDE are running simultaneously, they can exchange 
information and commands.

Key disk — A floppy disk that can be used to activate the software even if that disk 
contains zero licenses. The Master Disk is the only key disk. This differs from an 
activation disk in that an activation disk must contain at least one license.

License — Authorization to use a specified number of instances of software. A product’s 
activation key contains a license for each copy of the software you have purchased. For 
example, if you bought seven copies of RSLinx Classic, then the RSLinx Classic key on 
the Master Disk contains seven “licenses” of RSLinx Classic. You can move the 
activation file for RSLinx Classic to seven different computers.

Links — The data path established for one or more channels between two or more 
stations. DDE links can be hot, warm, or cold.

Master disk — This disk is supplied with the software. It contains a database of keys in 
an “activation file” that enables the software to run. Be sure to store your Master Disk in a 
safe place. If your activation file becomes damaged, the only way you can run your 
software (until the activation is reset) is with your Master Disk.
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OPC — Provides an industry-standard mechanism to communicate and exchange data 
between clients and servers using OLE technology.

Packet — The transmission unit exchanged at the network layer.

Poke — DDE’s version of a write.

Read — To acquire data from somewhere (memory, an output, another station).

Topic — Represents a specific path to a processor.

Write — To load data into somewhere (memory, an output, another station).
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